常见问题

About 4 min

常见问题

安装python3过程中,提示“configure: error: no acceptable C compiler found in $PATH”

  • 现象描述

    安装python3过程中出现以下错误:

    configure: error: no acceptable C compiler found in $PATH. See 'config.log' for more details
    
    1
  • 可能原因

    环境中未安装“gcc”。

  • 解决办法

    1、通过命令“apt-get install gcc”在线安装。

    2、完成后,重新安装python3。

安装python3过程中,提示“-bash: make: command not found”

  • 现象描述

    安装python3过程中出现以下错误:

    -bash: make: command not found
    
    1
  • 可能原因

    环境中未安装“make”。

  • 解决办法

    1、通过命令“apt-get install make”在线安装。

    2、完成后,重新安装python3。

安装python3过程中,提示“zlib not available”

  • 现象描述

    安装python3过程中出现以下错误:

    zipimport.ZipImportError: can't decompress data; zlib not avaliable
    
    1
  • 可能原因

    环境中未安装“zlib”。

  • 解决办法

    方法1:通过命令“apt-get install zlib”在线安装。

    方法2:如果软件源中没有该软件,请从“www.zlib.net”下载版本代码,并离线安装。

    完成下载后,通过以下命令安装:

    # tar xvf zlib-1.2.11.tar.gz
    # cd zlib-1.2.11
    # ./configure
    # make && make install
    
    1
    2
    3
    4

    完成后,重新安装python3。

安装python3过程中,提示“No module named '_ctypes'”

  • 现象描述

    安装python3过程中出现以下错误:

    ModuleNotFoundError:No module named ‘_ctypes’
    
    1
  • 可能原因

    环境中未安装“libffi”和“libffi-devel”。

  • 解决办法

    1、通过命令“apt-get install libffi* -y”,在线安装。

    2、完成后,重新安装python3。

编译构建过程中,提示“No module named 'Crypto'”

  • 现象描述

    编译构建过程中出现以下错误:

    ModuleNotFoundError: No module named 'Crypto'
    
    1
  • 可能原因

    环境中未安装“Crypto”。

  • 解决办法

    方法1:通过命令“pip3 install Crypto”,在线安装。

    方法2:离线安装

    通过网页https://pypi.org/project/pycrypto/#files,下载源码。

    将源码放置在Linux服务器中,解压,并安装“python3 setup.py install”。

    完成上述安装后,重新构建。

编译构建过程中,提示“No module named 'ecdsa'”

  • 现象描述

    编译构建过程中出现以下错误:

    ModuleNotFoundError:No module named 'ecdsa'
    
    1
  • 可能原因

    环境中未安装“ecdsa”。

  • 解决办法

    方法1:通过命令“pip3 install ecdsa”,在线安装。

    方法2:离线安装

    通过网页https://pypi.org/project/ecdsa/#files,下载安装包。

    将安装包放置Linux服务器中,并安装“pip3 install ecdsa-0.15-py2.py3-none-any.whl”。

    完成上述安装后,重新构建。

编译构建过程中,提示“Could not find a version that satisfies the requirement six>=1.9.0”

  • 现象描述

    编译构建过程中出现以下错误:

    Could not find a version that satisfies the requirement six>=1.9.0
    
    1
  • 可能原因

    环境中未安装合适的“six”。

  • 解决办法

    方法1:通过命令“pip3 install six”,在线安装。

    方法2:离线安装

    通过网页https://pypi.org/project/six/#files,下载安装包。

    将源码放置在Linux服务器中,并安装“pip3 install six-1.14.0-py2.py3-none-any.whl”。

    完成上述安装后,重新构建。

编译构建过程中,提示找不到“-lgcc”

  • 现象描述

    编译构建过程中出现以下错误:

    riscv32-unknown-elf-ld: cannot find -lgcc
    
    1
  • 可能原因

    交叉编译器gcc_riscv32的PATH添加错误,如下,在"bin"后多添加了一个“/”,应该删除。

    ~/gcc_riscv32/bin/:/data/toolchain/
    
    1
  • 解决办法

    重新修改gcc_riscv32的PATH,将多余的“/”删除。

    ~/gcc_riscv32/bin:/data/toolchain/
    
    1

编译构建过程中,提示找不到“python”

  • 现象描述

    编译构建过程中出现以下错误:

    -bash: /usr/bin/python: No such file or directory
    
    1
  • 可能原因1

    没有装python。

  • 解决办法

    请按照安装Python环境

  • 可能原因2

  • 解决办法

    usr/bin目录下没有python软链接,请运行以下命令添加软链接:

    # cd /usr/bin/
    # which python3
    # ln -s /usr/local/bin/python3 python
    # python --version
    
    1
    2
    3
    4

    例:

安装 kconfiglib时,遇到lsb_release错误

  • 现象描述

    安装kconfiglib过程中遇到如下错误打印:

    subprocess.CalledProcessError: Command '('lsb_release', '-a')' returned non-zero exit status 1.
    
    1
  • 可能原因

    lsb_release模块基于的python版本与现有python版本不一致

  • 解决办法

    执行"find / -name lsb_release",找到lsb_release位置并删除,如:"sudo rm -rf /usr/bin/lsb_release"