安装开发板环境

About 3 min

安装开发板环境

Hi3518环境搭建

硬件要求

  • Hi3518EV300 IoT Camera开发板

  • USB转串口线、网线(Windows工作台通过USB转串口线、网线与开发板连接)

    各硬件连接关系如下图所示。

    图 1 硬件连线图

软件要求

须知: 本节描述安装包方式搭建编译环境的操作步骤。如果是Docker方式安装编译环境,请跳过此章节以及下述安装Linux服务器工具章节。

Hi3518开发板对Linux服务器通用环境配置需要的工具及其获取途径如下表所示。

表 1 Linux服务器开发工具及获取途径

开发工具

用途

获取途径

bash

命令行处理工具

系统配置

编译基础软件包(仅ubuntu 20+需要)

编译依赖的基础软件包

通过互联网获取

dosfstools、mtools、mtd-utils

文件打包工具

通过apt-get install安装

安装Linux服务器工具

须知:

  • 如果通过“HPM组件方式”或“HPM包管理器命令行工具方式”获取源码,不需要安装hc-gen编译工具。
  • (推荐)如果通过“镜像站点方式”或“代码仓库方式”获取源码,需要安装hc-gen编译工具。安装hc-gen编译工具时,请确保编译工具的环境变量路径唯一。

将Linux shell改为bash

查看shell是否为bash,在终端运行如下命令

ls -l /bin/sh
1

如果显示为“/bin/sh -> bash”则为正常,否则请按以下方式修改:

方法一:在终端运行如下命令,然后选择 no。

sudo dpkg-reconfigure dash
1

方法二:先删除sh,再创建软链接。

sudo rm -rf /bin/sh
sudo ln -s /bin/bash /bin/sh
1
2

安装编译依赖基础软件(仅Ubuntu 20+需要)

执行以下命令进行安装:

sudo apt-get install build-essential gcc g++ make zlib* libffi-dev
1

安装文件打包工具

  1. 打开Linux编译服务器终端。

  2. 运行如下命令,安装dosfstools,mtools,mtd-utils。

    sudo apt-get install dosfstools mtools mtd-utils
    
    1